Connection issue
Incident Report for TeamViewer
Resolved
The issue has been resolved.
Posted 10 months ago. Oct 09, 2018 - 09:57 CEST
Monitoring
The issue has been resolved. Our engineers are still monitoring our systems to assure the situation is completely mitigated.
Posted 10 months ago. Oct 09, 2018 - 08:25 CEST
Investigating
A subset of our users are currently experiencing latency or errors when accessing our TeamViewer services. Our engineers have not yet confirmed the underlying root cause. We will publish the next status as soon as possible.
Posted 10 months ago. Oct 09, 2018 - 08:00 CEST
This incident affected: TeamViewer Services, Management Console, and API.