Managed devices

Incident Report for TeamViewer

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 11:56 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2026 - 11:18 CEST

Investigating

We are currently investigating an issue that causes managed devices to be missing from the device list.
Posted Apr 17, 2026 - 10:53 CEST
This incident affected: TeamViewer Services and Management Console.