Connectivity issues in Russia
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted about 1 month ago. May 18, 2018 - 17:11 CEST
Investigating
A subset of our users are currently experiencing latency or errors when accessing our service TeamViewer. Our engineers have not yet confirmed the underlying root cause. We will publish the next status update at the latest in 24 hours.
Posted about 1 month ago. May 17, 2018 - 17:36 CEST
This incident affected: TeamViewer Services.