Connectivity Issue
Incident Report for TeamViewer
Resolved
All our systems are now back online and functional.
Posted 4 months ago. Nov 08, 2018 - 18:02 CET
Monitoring
Everything is back online and running. Still - we are monitoring the services.
Posted 4 months ago. Nov 08, 2018 - 17:02 CET
Update
Dear users and customers. Connections to devices and through your Computer & Contact list has been restored again. We are now working on getting the full TeamViewer experience with Chat, Management Console and New Account creation back online. We are on it, further update to come.
Posted 4 months ago. Nov 08, 2018 - 16:07 CET
Update
We are still facing connectivity issues. Next update will follow soon.
Posted 4 months ago. Nov 08, 2018 - 15:50 CET
Update
Dear users and customers. Connections to existing as well as new devices with ID´s and through your Computer & Contact list has been restored. We are now working on getting the full TeamViewer experience with Chat, Management Console and New Account creation back online. We are on it, further update to come.
Posted 4 months ago. Nov 08, 2018 - 15:22 CET
Update
UPDATE: The connectivity issue has been partially mitigated and we see more and more users being able to work again. We keep on working to get everyone back online as soon as possible
Posted 4 months ago. Nov 08, 2018 - 14:54 CET
Update
Dear Users and Customers. Approximately 30 minutes ago we started to get our services progressively online for account login and establishing connections. Thanks much for you continued patience. Update to come.
Posted 4 months ago. Nov 08, 2018 - 14:17 CET
Update
We are getting back progressively online.
Posted 4 months ago. Nov 08, 2018 - 13:47 CET
Identified
The issue has been identified and we are working on putting our services progressively online again. (connection and account login)
During this time, you might still experience connectivity issues.
Posted 4 months ago. Nov 08, 2018 - 13:20 CET
Update
We are continuing to investigate this issue.
Posted 4 months ago. Nov 08, 2018 - 12:19 CET
Update
We are continuing to investigate this issue.
Posted 4 months ago. Nov 08, 2018 - 11:48 CET
Update
We are continuing to investigate this issue.
Posted 4 months ago. Nov 08, 2018 - 11:26 CET
Investigating
Our users are currently experiencing latency or errors when connecting to their devices. Our engineers have not yet confirmed the underlying root cause. We will publish the next status update at the latest in 60 minutes.
Posted 4 months ago. Nov 08, 2018 - 11:23 CET
This incident affected: TeamViewer Services, Management Console, API, and IoT.