Longer loading times
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted Aug 28, 2023 - 12:45 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2023 - 13:50 CEST
Update
We are continuing to work on a fix for this issue.
Posted Aug 17, 2023 - 14:55 CEST
Identified
A subset of users experiencing long loading times for their device lists.
Posted Aug 17, 2023 - 14:45 CEST
This incident affected: TeamViewer Services and Management Console.