Partial DNS Outage

Incident Report for TeamViewer

Resolved

All our systems are back online and functional.
Posted Aug 18, 2026 - 00:31 CEST

Update

We are continuing to investigate this issue.
Posted Aug 17, 2026 - 18:17 CEST

Update

A potential cause has been identified and we're monitoring the situation
Posted Aug 17, 2026 - 18:10 CEST

Investigating

We are currently investigating an issue with Login issues and/or connection establishments. A TeamViewer Client restart could resolve the issue.
Posted Aug 17, 2026 - 16:52 CEST
This incident affected: TeamViewer Services.