Degraded Performance
Incident Report for TeamViewer
Resolved
We fixed the connectivity issue and all our systems are back online and functional.
Posted Feb 01, 2023 - 21:23 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 01, 2023 - 18:21 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 01, 2023 - 17:16 CET
Investigating
A subset of our users are currently experiencing latency when accessing our services. Our engineers have not yet confirmed the underlying root cause and they are working on the identification. We will update our status page with new information as soon as possible.
Posted Feb 01, 2023 - 16:20 CET
This incident affected: TeamViewer Services and Management Console.