Remote & Tensor : Degraded Performance

Incident Report for TeamViewer

Resolved

This incident has been resolved.
Posted Sep 24, 2026 - 14:31 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 24, 2026 - 10:27 CEST

Identified

We have identified an issue that may cause delays in the delivery of some outbound emails. Our engineers are working on a resolution and we will provide updates as they become available.
Posted Sep 23, 2026 - 23:52 CEST
This incident affected: TeamViewer Services.