Log in issue with our services
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted Aug 03, 2021 - 10:05 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 03, 2021 - 09:29 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 03, 2021 - 08:58 CEST
Investigating
We are experiencing high load on our master servers.

We are currently investigating the issue.
Posted Aug 03, 2021 - 08:28 CEST
This incident affected: TeamViewer Services and Management Console.