Degraded Performance
Incident Report for TeamViewer
Resolved
We fixed the connectivity issue and all our systems are back online and functional.
Posted 3 months ago. May 05, 2019 - 20:38 CEST
Identified
Our engineers identified the underlying root cause for the degraded performance and are working on the resolution. We will update our status page with new information as soon as possible.
Posted 3 months ago. May 05, 2019 - 19:01 CEST
This incident affected: TeamViewer Services, Management Console, and API.