License activation issue

Incident Report for TeamViewer

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 16:09 CET

Investigating

We are currently having issues with license activation on some instances. We´re currently investigating this issue.
Posted Oct 30, 2025 - 15:46 CET
This incident affected: TeamViewer Services.