Degraded Performance

Incident Report for TeamViewer

Resolved

We fixed the degraded performance and all our systems are back online and functional.
Posted Mar 14, 2023 - 10:54 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2023 - 10:13 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 14, 2023 - 09:44 CET

Investigating

We are currently investigating this issue.
Posted Mar 14, 2023 - 09:27 CET
This incident affected: API.