Connection issue - South America
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted Dec 01, 2022 - 17:31 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 01, 2022 - 17:05 CET
Investigating
We are experiencing some connection issues in South America and already investigating the root cause.
Posted Dec 01, 2022 - 16:31 CET
This incident affected: TeamViewer Services.